Moodle Technical Requirements

Browser Requirements

To use Moodle effectively it is recommended that you run one of the following browsers (minimum version and recommended version of each is indicated):

  • Google Chrome (version 30 minimum, latest version recommended)
  • Mozilla Firefox (version 25 minimum, latest version recommended)
  • Apple Safari (version 6 minimum, latest version recommended)
  • Internet Explorer (version 9 minimum, latest version recommended)

In addition, within the browser:

  • javascript must be enabled
  • pop-up windows must not be blocked for SCC's Moodle

These requirements only apply to using Moodle's core features, not to any external sites or services that instructors may link to or embed within their Moodle courses.